Помощь по плагину к амх 1.9.0

Sekret

Участник
Сообщения
58
Симпатии
13
Баллы
64
#1
ребят привет) вопрос на миллион, а у нас на форуме случайно нет специалистов которые плагины перековырять могу под 1.9.0 ну или на 1.8.3 (вроде на 190 должен будет завестись)
Перешёл на 1.9.0 (да да по дурости) но отступать некуда иплагины которые раньше были (один на примере покажу ниже) перестали работать в особеннности худ оповещения и таймеры и так далее, некоторые как weaponrest вообще отказываються работать как и авп плагины, так вот вопрос такой, их надо полностью переписывать или небольшая корректировка? пример вот на таймере хотя бы
#include <amxmodx>
#include <csx>

#define PLUGIN "C4 Timer"
#define VERSION "1.1"
#define AUTHOR "SAMURAI & Remod: programer"

new g_c4timer
new pointnum

new bool:b_planted = false

new g_HudMsg

public plugin_init()
{
register_plugin(PLUGIN, VERSION, AUTHOR)

pointnum = get_cvar_pointer("mp_c4timer")
register_logevent("RoundStart", 2, "1=Round_Start")
register_logevent("RoundEnd", 2, "1=Round_End")
register_logevent("RoundEnd", 2, "1&Restart_Round_")

g_HudMsg = CreateHudSyncObj()

register_dictionary("file.txt")
}

public RoundStart()
{
g_c4timer = -1
remove_task(55)
b_planted = false
}

public RoundEnd()
{
g_c4timer = -1
remove_task(55)
}

public bomb_planted()
{
b_planted = true;
g_c4timer = get_pcvar_num(pointnum);
ShowTime()
set_task(1.0, "ShowTime", 55, _, _, "b")
}

public bomb_defused()
{
if(b_planted)
{
remove_task(55)
b_planted = false
}
}

public bomb_explode()
{
if(b_planted)
{
remove_task(55)
b_planted = false
}
}

public ShowTime()
{
if(!b_planted)
{
remove_task(55)
return
}

if(g_c4timer >= 0)
{
set_hudmessage(171, 57, 57, -1.0, 0.80, 0, 1.0, 1.0, 0.01, 0.01, -1);
ShowSyncHudMsg(0, g_HudMsg, "%L", LANG_PLAYER, "MESSAGE", EndWord(g_c4timer))
--g_c4timer
}

}

stock EndWord( iNum )
{
new szText[128]
new iLen

iLen += formatex(szText, charsmax( szText ) - iLen, "%d ", iNum);

switch( iNum )
{
case 1, 21, 31, 41, 51:
{
iLen += formatex(szText[iLen], charsmax( szText ) - iLen, "%L", LANG_PLAYER, "ITEM_1")
}

case 2..4, 22..24, 32..34, 42..44, 52..54:
{
iLen += formatex(szText[iLen], charsmax( szText ) - iLen, "%L", LANG_PLAYER, "ITEM_2")
}

default:
{
iLen += formatex(szText[iLen], charsmax( szText ) - iLen, "%L", LANG_PLAYER, "ITEM_3")
}
}
return szText
}
 

Sekret

Участник
Сообщения
58
Симпатии
13
Баллы
64
#2
просто насколько я знаю то мало кто щас пишет или переписывает плагины под 1.9.0, получается много времени и денег уйдёт на устранение и исправление каждого проблемного плагина)встревалово)
 

Sekret

Участник
Сообщения
58
Симпатии
13
Баллы
64
#4
Оффтоп
>> но отступать некуда
А что держит?
Дэн держит то что я уже два дня бьюсь не покладая "чела")) уже принцип пошёл)) и тп уже мне как тока не помогала и уже со скриптером на субботу договорился) но вот мнение народа тоже интересно, просто кроме нашего СашиFinera занимается переходами, переделками, а то у него и времени нет обсудить, а интересно же) или найдётся энтузиаст как когда то неугомон, занялся и много плагинов написал, но потом он перешёл на уровень выше и уже не до плагинов)
 

Sekret

Участник
Сообщения
58
Симпатии
13
Баллы
64
#6
Sekret, потеряешь время и деньги. И все равно откатишься на старую версию :geek:
а всё, я не могу перейти на 190) у меня физ машина гамно и нового ничего там больше не установить) даже новую версию AES) стата вроде встаёт, Велерий пытался мне сегодня сделать но не смог и сказал вот тебе версия с Бэкапа) так что мне просто не повезло с сервером) а вот на втором тестовом всё работает)
 
Сверху